summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2022-11-21 12:56:37 +0100
committerLubosz Sarnecki2022-11-21 15:05:52 +0100
commit39cb41f3d2e546a5e921e9a84af55fa98fa09fd3 (patch)
treeb45b16117eed939f0f08054ef6ae2beb4fbd313f /PKGBUILD
parent27b3dba77284db812953a151be8477f4c5f5b34f (diff)
downloadaur-libappindicator-bzr.tar.gz
Various improvements.
* Update description * Remove invalid replaces variable * Parse actual version from configure.ac * Add version to provides * Add mono build dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b62b478bfcfa..e30c5d75ea1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,29 +7,30 @@
# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=("libappindicator-bzr")
-pkgver=296
+pkgver=12.10.0.r298
pkgrel=1
-pkgdesc='Allow applications to extend a menu via Ayatana indicators in Unity, KDE or Systray. GTK+ 3 Bzr version.'
+pkgdesc='A library to allow applications to export a menu into the Unity Menu bar. GTK3 Bzr version.'
url='https://launchpad.net/libappindicator'
-arch=('x86_64')
-license=('LGPL2.1' 'LGPL3')
-makedepends=('dbus-glib' 'gobject-introspection' 'libdbusmenu-gtk3' 'libindicator-gtk3' 'vala' 'gnome-common' 'gtk-sharp-2' 'gtk-sharp-3' 'perl-xml-libxml' 'bzr' 'automake')
-depends=('libdbusmenu-gtk3')
-options=('!emptydirs')
+arch=(x86_64)
+license=(LGPL2.1 LGPL3)
+makedepends=(dbus-glib gobject-introspection libdbusmenu-gtk3 libindicator-gtk3 vala gnome-common gtk-sharp-2 gtk-sharp-3 perl-xml-libxml bzr automake mono)
+depends=(libdbusmenu-gtk3)
+options=(!emptydirs)
source=('bzr+lp:libappindicator')
-conflicts=('libappindicator-gtk3')
-replaces=('libappindicator-gtk3')
-provides=('libappindicator-gtk3')
+conflicts=(libappindicator-gtk3)
+provides=(libappindicator-gtk3=$pkgver)
sha512sums=('SKIP')
pkgver() {
cd libappindicator
- bzr revno
+ ver=`grep "AC_INIT" configure.ac -A1 | tail -1 | sed "s# \[##" | sed "s#\],##"`
+ _bzrrev=`bzr revno`
+ echo "${ver}.r${_bzrrev}"
}
build() {
- export CFLAGS="${CFLAGS} -Wno-deprecated-declarations"
+ # Without this gapi2-codegen will fail
export CSC='/usr/bin/mcs'
(cd libappindicator
@@ -37,7 +38,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--with-gtk=3
- make
+ make -j1
)
}