summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhorsemanoffaith2018-03-10 22:48:04 -0800
committerhorsemanoffaith2018-03-10 22:48:04 -0800
commit311f6e2f5be9e91ad16b104ddff96882b664b2c1 (patch)
tree90dc266c9c94c86aa5c78a678e04850f6edb1f58 /PKGBUILD
parentbfd61b5b791cc6d24f707a61f33ede4382e4ddc6 (diff)
downloadaur-311f6e2f5be9e91ad16b104ddff96882b664b2c1.tar.gz
update to version 12.10.1.17.04.20170215
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86a31a3f0e6a..e382905866e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: thn81 <root@scrat>
# vercheck-pkgbuild: auto
-# vercheck-ubuntu: name=${pkgbase}, repo=zesty
+# vercheck-ubuntu: name=${pkgbase}, repo=bionic
# vercheck-launchpad: name=${pkgbase}
pkgbase=libappindicator-ubuntu
pkgname=(libappindicator-gtk2-ubuntu libappindicator-gtk3-ubuntu)
_actual_ver=12.10.1
-_extra_ver=+17.04.20161129
+_extra_ver=+17.04.20170215
pkgver=${_actual_ver}${_extra_ver/\+/.}
pkgrel=1
pkgdesc="A library to allow applications to export a menu into the Unity Menu bar"
@@ -21,17 +21,14 @@ makedepends=(dbus-glib gobject-introspection gtk-doc gtk-sharp-2 libdbusmenu-gtk
groups=(unity)
source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgbase/\-*/}_${_actual_ver}${_extra_ver}.orig.tar.gz"
0001-Glib.Timeout-fix.patch
- 0002-Fix-mono-nunit-pkgconfig-name.patch
0003-Fix-Mono-assemblies-directory.patch)
-sha512sums=('9ef7c14350bc9397f5aafb31ba399b55674b5034ac59a9ec69b24e403e0e9bd056ace03861ad7671e9c5ce4d998adb58e718e7a31125affc6bb5d1f49aa50d1f'
+sha512sums=('a3ab2418e240b912a5e64473e53a085fe5985d2b2d3b318003309833aa518daa1e241b6b67c264a74526a199ee66559bbf970bd5c0117e806e59bcf1c85f04de'
'3303fa39c4f2e0d9d092735ae7b457873cf4b3a3b0dd5c1f492728ae4f12dc3f0f123a1b003d81e9b5164b13dea71d598fae01fd667c24cf6983155d58cecb4c'
- 'ea1822c3a09ef4c59d91b267d2ea0d0c9003c04ea0d8d4fb6a73e1b51084faccafbf41d6390a9c0e1326fd3334421539bdbb86a2a5e5022fa96e9d5196ef2d1d'
'22e15f875a636bbbf8b1e80867a219b4b47b334d1bfe759f4ce79bf3665fc63af36b57fddb6c92aa7db148b5ea9ed789e510a9b23d87324b1b48695ad1ca9bc7')
prepare() {
patch -p1 -i ../0001-Glib.Timeout-fix.patch
- patch -p1 -i ../0002-Fix-mono-nunit-pkgconfig-name.patch
patch -p1 -i ../0003-Fix-Mono-assemblies-directory.patch
}
@@ -44,14 +41,14 @@ build() {
[[ -d build-gtk2 ]] || mkdir build-gtk2
pushd build-gtk2
- ../configure --prefix=/usr --with-gtk=2 --disable-static \
+ ../configure --prefix=/usr --with-gtk=2 --disable-static --disable-mono-test \
PYTHON=python2 CSC=/usr/bin/mcs
make -j1
popd
[[ -d build-gtk3 ]] || mkdir build-gtk3
pushd build-gtk3
- ../configure --prefix=/usr --with-gtk=3 --disable-static \
+ ../configure --prefix=/usr --with-gtk=3 --disable-static --disable-mono-test \
PYTHON=python2 CSC=/usr/bin/mcs
make -j1
popd
@@ -59,6 +56,8 @@ build() {
package_libappindicator-gtk2-ubuntu() {
pkgdesc+=" (GTK+ 2 library)"
+ provides=(libappindicator-gtk2)
+ conflicts=(libappindicator-gtk2)
depends=(libindicator-gtk2-ubuntu libdbusmenu-gtk2-ubuntu)
cd build-gtk2
@@ -68,6 +67,8 @@ package_libappindicator-gtk2-ubuntu() {
package_libappindicator-gtk3-ubuntu() {
pkgdesc+=" (GTK+ 3 library)"
+ provides=(libappindicator-gtk3)
+ conflicts=(libappindicator-gtk3)
depends=(libindicator-gtk3-ubuntu libdbusmenu-gtk3-ubuntu)
cd build-gtk3