summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesin2017-11-07 15:01:05 -0500
committerJesin2017-11-07 15:01:05 -0500
commit0ecb6741320594ff9c69e89e71d019dbebda07e0 (patch)
tree587a19def4218f96f33cb7d831d6658a9a8a493a /PKGBUILD
parent413f2ea51a817a062e63c2998a0b0b0c885e16e9 (diff)
downloadaur-0ecb6741320594ff9c69e89e71d019dbebda07e0.tar.gz
define check()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f13b2798097a..fe4b96006138 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jesin <Jesin00@gmail.com>
pkgname=libb2
-pkgver=0.0.15.g9a0d006
-pkgrel=2
+pkgver=0.0.17.g0d7015f
+pkgrel=1
arch=(i686 x86_64)
pkgdesc='C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions'
url=https://blake2.net/
@@ -18,7 +18,7 @@ prepare() {
cd "$pkgname"
# If there are no tags, tag the initial commit so pkgver() can work.
[ -n "$(git tag)" ] || git tag 0.0 "$(git rev-list --max-parents=0 --reverse HEAD | head -n1)"
- autoreconf -fiv
+ autoreconf -fisv
}
pkgver() {
@@ -35,6 +35,11 @@ build() {
make
}
+check() {
+ cd "$pkgname"
+ make check
+}
+
package() {
cd "$pkgname"
make "DESTDIR=$pkgdir" install