summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:25:45 -0800
committerAndy Weidenbaum2017-03-08 12:25:45 -0800
commit702ac358b532c714a4b476be7df6bc815f598199 (patch)
tree1574448832eb5241b37e9e8e9f3ef59d20b52f79 /PKGBUILD
parent505b6a8c1735531d69aa187cb8ea4eb2e63d17e8 (diff)
downloadaur-702ac358b532c714a4b476be7df6bc815f598199.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51c27460257b..a1f88537a400 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-client
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Client Protocol Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -38,11 +38,17 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-client \
--localstatedir=/var/lib/libbitcoin-client \
--with-gnu-ld \
- --without-examples \
- --without-tests
+ --without-examples
make -j$(($(nproc)/2))
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"