summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commit64254e0ea73c3cbf9fe2cf7b454606f9ae65531d (patch)
treef9f5eebef8f8d12d8717efea8cb0c2773d2542cd /PKGBUILD
parent7104d87107128fa167a7f3337137c1e7fc23ad4a (diff)
downloadaur-64254e0ea73c3cbf9fe2cf7b454606f9ae65531d.tar.gz
increment pkgrel; fix make -j for nproc=1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acf0411f7e19..37243a7947b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-consensus
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Consensus Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -21,6 +21,10 @@ license=('AGPL3')
source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/libbitcoin/$pkgname/tar.gz/v$pkgver)
sha256sums=('1e70f8c80a1a8089e5a5061310dab9fa069d1e3b221f442dc79545f130644da9')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -34,14 +38,14 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-consensus \
--localstatedir=/var/lib/libbitcoin-consensus \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd "$srcdir/$pkgname-$pkgver"
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {