summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:25:44 -0800
committerAndy Weidenbaum2017-03-08 12:25:44 -0800
commit840fa522e6a6b2837ae37fcc670cdf8c1ac10041 (patch)
treedc10d707d3f53aed8907d5709029410db74a2caf /PKGBUILD
parentf60ef6e11f6022cff7ce548798e78aea9a8986b3 (diff)
downloadaur-840fa522e6a6b2837ae37fcc670cdf8c1ac10041.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0381f439f853..ef3a77864897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-consensus
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Consensus Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -33,11 +33,17 @@ build() {
--sysconfdir=/etc \
--sharedstatedir=/usr/share/libbitcoin-consensus \
--localstatedir=/var/lib/libbitcoin-consensus \
- --with-gnu-ld \
- --without-tests
+ --with-gnu-ld
make -j$(($(nproc)/2))
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"