summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commitc77fcf9cbac465d1caa27cb0fd55ad6e24245243 (patch)
tree7a83fb801cfa832aca63eccfeab6553b7abb67ef /PKGBUILD
parent748473ffeac1497e1f55b44082452b855e088221 (diff)
downloadaur-c77fcf9cbac465d1caa27cb0fd55ad6e24245243.tar.gz
increment pkgrel; fix make -j for nproc=1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1c52abfcf61..54958f310a45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-database-git
pkgver=20170303
-pkgrel=2
+pkgrel=3
pkgdesc="Bitcoin High Performance Blockchain Database"
arch=('i686' 'x86_64')
depends=('boost'
@@ -25,6 +25,10 @@ sha256sums=('SKIP')
provides=('libbitcoin-database')
conflicts=('libbitcoin-database')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
pkgver() {
cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -43,14 +47,14 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-database \
--localstatedir=/var/lib/libbitcoin-database \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd ${pkgname%-git}
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {