summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:27:11 -0800
committerAndy Weidenbaum2017-03-08 12:27:11 -0800
commit0730141a178717ae7b3258bed5848a2e9acaff81 (patch)
treecf71010260899b468a2a6c3f94468824802d634f /PKGBUILD
parent566728a88043e22bafa8a36d9ee82b1de7c7103e (diff)
downloadaur-0730141a178717ae7b3258bed5848a2e9acaff81.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 042da6bba99c..991811e1e7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-explorer-git
pkgver=20170307
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Command Line Tool"
arch=('i686' 'x86_64')
depends=('boost'
@@ -51,11 +51,17 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-explorer \
--localstatedir=/var/lib/libbitcoin-explorer \
--with-bash-completiondir=/usr/share/bash-completion/completions \
- --with-gnu-ld \
- --without-tests
+ --with-gnu-ld
make -j$(($(nproc)/2))
}
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd ${pkgname%-git}