summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commite74e88485bdfe3a8c6a325103cb8414fbe592a83 (patch)
treebc10c5347e573e31fd03cb7a37d6e6abd7261c3b /PKGBUILD
parent0730141a178717ae7b3258bed5848a2e9acaff81 (diff)
downloadaur-e74e88485bdfe3a8c6a325103cb8414fbe592a83.tar.gz
increment pkgrel; fix make -j for nproc=1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 991811e1e7b1..35bcd3006db7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-explorer-git
pkgver=20170307
-pkgrel=2
+pkgrel=3
pkgdesc="Bitcoin Command Line Tool"
arch=('i686' 'x86_64')
depends=('boost'
@@ -33,6 +33,10 @@ sha256sums=('SKIP' 'SKIP')
provides=('libbitcoin-explorer')
conflicts=('libbitcoin-explorer')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
pkgver() {
cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -52,14 +56,14 @@ build() {
--localstatedir=/var/lib/libbitcoin-explorer \
--with-bash-completiondir=/usr/share/bash-completion/completions \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd ${pkgname%-git}
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {