summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commit6605296573e930fec5fdecd7536e71bbbdbe3fc8 (patch)
treee22608fdfdea7e605ba390835bea22aa78f4d4a8 /PKGBUILD
parentd8384979623dd3a2e4760442a4a272ae3e2b5cce (diff)
downloadaur-6605296573e930fec5fdecd7536e71bbbdbe3fc8.tar.gz
increment pkgrel; fix make -j for nproc=1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d4fcd5f923e..3726b323a09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libbitcoin-network-git
pkgver=20170307
-pkgrel=2
+pkgrel=3
pkgdesc="Bitcoin P2P Network Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -28,6 +28,10 @@ sha256sums=('SKIP')
provides=('libbitcoin-network')
conflicts=('libbitcoin-network')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
pkgver() {
cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -46,14 +50,14 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-network \
--localstatedir=/var/lib/libbitcoin-network \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd ${pkgname%-git}
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {