summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:27:09 -0800
committerAndy Weidenbaum2017-03-08 12:27:09 -0800
commitd8384979623dd3a2e4760442a4a272ae3e2b5cce (patch)
tree528c75c3ae8ec107ed5bbd6e59c70dea17b164f0 /PKGBUILD
parent59d10eeb50858ff14e331f0ed6812e8e024947fe (diff)
downloadaur-d8384979623dd3a2e4760442a4a272ae3e2b5cce.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28350b5f8bca..3d4fcd5f923e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libbitcoin-network-git
pkgver=20170307
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin P2P Network Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -45,11 +45,17 @@ build() {
--sysconfdir=/etc \
--sharedstatedir=/usr/share/libbitcoin-network \
--localstatedir=/var/lib/libbitcoin-network \
- --without-tests \
--with-gnu-ld
make -j$(($(nproc)/2))
}
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd ${pkgname%-git}