summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:27:18 -0800
committerAndy Weidenbaum2017-03-08 12:27:18 -0800
commit08bce7915b9e8433385240be37509515bc7563f9 (patch)
treee91bcffd4049e206521800f5044bcf71053bfbb2 /PKGBUILD
parent53d9b4ecc1eaf15704f5b7614e6d383f2efcf790 (diff)
downloadaur-08bce7915b9e8433385240be37509515bc7563f9.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2f5555a1bf6..2a643546c6d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-server-git
pkgver=20170307
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Full Node and Query Server"
arch=('i686' 'x86_64')
depends=('boost'
@@ -77,11 +77,17 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-server \
--localstatedir=/var/lib/libbitcoin-server \
--with-bash-completiondir=/usr/share/bash-completion/completions \
- --with-gnu-ld \
- --without-tests
+ --with-gnu-ld
make -j$(($(nproc)/2))
}
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd ${pkgname%-git}