summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:25:39 -0800
committerAndy Weidenbaum2017-03-08 12:25:39 -0800
commitb94298dd1a68d2f566d2ed90d3541b09e258840f (patch)
treed78dbd2ed598aa63aa1ac828b854b734492f191d /PKGBUILD
parentbb5511ac0fc717af21576bfbd14d25c78b9adaf5 (diff)
downloadaur-b94298dd1a68d2f566d2ed90d3541b09e258840f.tar.gz
increment pkgrel to 2; run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0024c2f83f1..db01f0ab459b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libbitcoin-system
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Cross-Platform C++ Development Toolkit"
arch=('i686' 'x86_64')
depends=('boost'
@@ -47,11 +47,17 @@ build() {
--with-png \
--with-qrencode \
--with-gnu-ld \
- --without-examples \
- --without-tests
+ --without-examples
make -j$(($(nproc)/2))
}
+check() {
+ cd "$srcdir/libbitcoin-$pkgver"
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd "$srcdir/libbitcoin-$pkgver"