summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072024-04-20 17:53:33 +0200
committersL1pKn072024-04-20 17:53:33 +0200
commitde48bc3643bff9a264fcfda530b4197d4757441a (patch)
treea221a32e00f135da95725bd08fc8d24af142f462 /PKGBUILD
parent2a5b641194fd1fb4937e314c30bee9c736e14949 (diff)
downloadaur-libbluray-git.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cb5b34f6c1c..2145ef231cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=libbluray-git
pkgver=1.3.4.0.gbb5bc108
pkgrel=1
-pkgdesc="Library to access Blu-Ray disks for video playback. (GIT version)"
+pkgdesc='Library to access Blu-Ray disks for video playback. (GIT version)'
arch=('x86_64')
license=('LGPL2.1')
url='https://www.videolan.org/developers/libbluray.html'
depends=(
- 'libxml2' 'libxml2.so'
- 'fontconfig' 'libfontconfig.so'
- 'freetype2' 'libfreetype.so'
- 'libudfread' 'libudfread.so'
+ 'libxml2'
+ 'fontconfig'
+ 'freetype2'
+ 'libudfread'
)
makedepends=(
'git'
@@ -22,10 +22,7 @@ optdepends=(
'libaacs: Enable AACS decryption'
'java-runtime: BD-J library'
)
-provides=(
- 'libbluray'
- 'libbluray.so'
-)
+provides=('libbluray')
conflicts=('libbluray')
source=('git+https://code.videolan.org/videolan/libbluray.git')
sha256sums=('SKIP')
@@ -55,5 +52,12 @@ build() {
}
package() {
+ depends+=(
+ 'libxml2.so'
+ 'libfontconfig.so'
+ 'libfreetype.so'
+ 'libudfread.so'
+ )
+
make -C build DESTDIR="${pkgdir}" install
}