summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-04-17 18:06:43 +0200
committersL1pKn072019-04-17 18:06:43 +0200
commit46e693cc6b63f618af3e6c198c712c2882f6ecdc (patch)
tree3f3e92200f3a08ec10e09f12d41c323dcfb613e5 /PKGBUILD
parentacd74b475b203fdd3f74c91670d9d41d608a7d74 (diff)
downloadaur-46e693cc6b63f618af3e6c198c712c2882f6ecdc.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85888b6dff14..fec0e0659bb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libbluray-git
-pkgver=1.0.2.40.g2d18c709
+pkgver=1.1.1.13.g109bbb00
pkgrel=1
pkgdesc="Library to access Blu-Ray disks for video playback. (GIT version)"
arch=('x86_64')
@@ -12,18 +12,18 @@ depends=('libxml2'
)
makedepends=('git'
'apache-ant'
- 'java-environment<=8'
+ 'java-environment<=11'
'libaacs'
)
optdepends=('libaacs: Enable AACS decryption'
- 'java-runtime: BD-J library'
+ 'java-runtime<=11: BD-J library'
)
provides=('libbluray'
'libbluray.so'
)
conflicts=('libbluray')
-source=('git+https://git.videolan.org/git/libbluray.git'
- 'git+https://git.videolan.org/git/libudfread.git'
+source=('git+https://code.videolan.org/videolan/libbluray.git'
+ 'git+https://code.videolan.org/videolan/libudfread.git'
)
sha256sums=('SKIP'
'SKIP'
@@ -37,7 +37,7 @@ pkgver() {
prepare() {
mkdir -p build
- export JDK_HOME="/usr/lib/jvm/default"
+ export JDK_HOME="/usr/lib/jvm/java-11-jdk"
cd libbluray
git config submodule.contrib/libudfread.url "${srcdir}/libudfread"
@@ -50,7 +50,8 @@ build() {
cd build
../libbluray/configure \
--prefix=/usr \
- --disable-static
+ --disable-static \
+ --with-java9
make
}