summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072019-02-12 16:47:58 +0100
committersL1pKn072019-02-12 16:47:58 +0100
commitacd74b475b203fdd3f74c91670d9d41d608a7d74 (patch)
tree94bb1cb22405d8e97d425868e86ba1332644694a /PKGBUILD
parent73cd37649cde62ef8ef07ace4dedca12028448ec (diff)
downloadaur-acd74b475b203fdd3f74c91670d9d41d608a7d74.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab35417068f8..85888b6dff14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libbluray-git
-pkgver=1.0.2.9.g8c15fdad
+pkgver=1.0.2.40.g2d18c709
pkgrel=1
pkgdesc="Library to access Blu-Ray disks for video playback. (GIT version)"
arch=('x86_64')
@@ -16,7 +16,7 @@ makedepends=('git'
'libaacs'
)
optdepends=('libaacs: Enable AACS decryption'
- 'java-environment: BD-J library'
+ 'java-runtime: BD-J library'
)
provides=('libbluray'
'libbluray.so'
@@ -35,17 +35,20 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
export JDK_HOME="/usr/lib/jvm/default"
cd libbluray
git config submodule.contrib/libudfread.url "${srcdir}/libudfread"
git submodule update --init
+
./bootstrap
}
build() {
- cd libbluray
- ./configure \
+ cd build
+ ../libbluray/configure \
--prefix=/usr \
--disable-static
@@ -53,5 +56,5 @@ build() {
}
package() {
- make -C libbluray DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
}