summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Brodsky2016-09-12 00:34:18 +0100
committerKevin Brodsky2016-09-12 00:34:28 +0100
commitad4300ec72b5f48ab0198477016b408d3b75c367 (patch)
treedf7ab32fc27908c60496976c90276e03b5b4af73 /PKGBUILD
parenta57f2f1d382228afc114c57ede36a9ae5d08feff (diff)
downloadaur-ad4300ec72b5f48ab0198477016b408d3b75c367.tar.gz
upgkpkg: 4.03.00-2
bobcat now uses C++14 (see INSTALL.im), while it still compiles in C++11 mode let's be use the appropriate option. INSTALL.im has also been updated to add -pthread to the CXXFLAGS for the files that actually need it, so we don't need to pass it ourselves anymore. (-pthread still has to be added to LDFLAGS, because makepkg.conf defines LDFLAGS, which overrides the defaults in INSTALL.im). Also fix the -P comment.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 461c9f491f60..8d69fc347bce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Anton Jongsma <anton@felrood.nl>
pkgname=libbobcat
pkgver=4.03.00
-pkgrel=1
+pkgrel=2
pkgdesc="Bobcat (Brokken's Own Base Classes And Templates) library"
arch=('i686' 'x86_64')
url="https://fbb-git.github.io/bobcat/"
@@ -17,10 +17,12 @@ md5sums=('c85f6793efbaf8dcd1079c4b5bf29a24')
build() {
cd "$srcdir/bobcat-${pkgver}/bobcat"
- CXXFLAGS="$CXXFLAGS --std=c++11 -pthread"
+
+ CXXFLAGS="$CXXFLAGS -std=c++14"
LDFLAGS="$LDFLAGS -pthread"
# Add the -P option not to use precompiled headers, which can be useful since
# they require a lot of free space, compared to a normal compilation:
+ # ./build -P libraries all
./build libraries all
./build man
}