summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTilduke2020-04-16 11:08:35 +0100
committerTilduke2020-04-16 11:08:35 +0100
commit47022d674df4de4bee78ba3b4cdf49b6842a27e4 (patch)
treefd669d37413b7380e77ec22b1b4f6778aa7a8448 /PKGBUILD
parent0797fc7270a059b108d576a6d35e9b0050c5aff5 (diff)
downloadaur-47022d674df4de4bee78ba3b4cdf49b6842a27e4.tar.gz
Modified URL and added new pkgver function to update version magically
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b7891bc2f27..77e6a17f26dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
_gitname=libbtbb
pkgname=libbtbb-git
-pkgver=2017.03.R2
+pkgver=2018.12.R1.r3.g6c7b9ff
pkgrel=1
pkgdesc='Bluetooth baseband decoding library'
url='https://github.com/greatscottgadgets/libbtbb'
arch=('x86_64' 'i686')
license=('GPL2')
makedepends=(cmake)
-depends=('python')
-source=("https://github.com/greatscottgadgets/libbtbb/archive/master.zip")
+depends=('python' 'git')
+source=("git+https://github.com/greatscottgadgets/libbtbb.git")
sha1sums=('SKIP')
build() {
- cd "${srcdir}/${_gitname}-master/"
+ cd "${srcdir}/${_gitname}/"
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
@@ -20,6 +20,11 @@ build() {
}
package() {
- cd "${srcdir}/${_gitname}-master/build/"
+ cd "${srcdir}/${_gitname}/build/"
make install
}
+
+pkgver() {
+ cd "${srcdir}/${_gitname}/"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}