summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-04-11 16:25:58 -0700
committerShadowKyogre2016-04-11 16:25:58 -0700
commitff40730732938978561bc6ca6af4fabfafcc3554 (patch)
tree04f780098fb5fdda0693290984d642bfcf3e9616 /PKGBUILD
parent41fe2afa29eec2c440d9699281575b748d0d2715 (diff)
downloadaur-ff40730732938978561bc6ca6af4fabfafcc3554.tar.gz
Standardize format of compiz git PKGBUILDs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 976895ca74f2..ca89f9452c94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,14 @@
# Contributor: JJDaNiMoTh <jjdanimoth@gmail.com>
# Contributor: nesl247 <nesl247@gmail.com>
+_upstream="libcompizconfig"
+
pkgname=libcompizconfig-git
pkgver=0.8.12.r2.g992eb5c
pkgrel=1
pkgdesc="Compiz configuration system library"
arch=('i686' 'x86_64')
-url="https://github.com/compiz-reloaded/libcompizconfig"
+url="https://github.com/compiz-reloaded/${_upstream}"
license=('GPL')
depends=('compiz-core' 'libxml2' 'libxcomposite' 'libxinerama' 'protobuf' 'startup-notification')
makedepends=('intltool' 'libxrandr' 'libice' 'libsm' 'mesa')
@@ -16,30 +18,23 @@ conflicts=('libcompizconfig')
provides=('libcompizconfig')
options=('!emptydirs')
source=(
- 'git+https://github.com/compiz-reloaded/libcompizconfig.git'
+ "git+https://github.com/compiz-reloaded/${_upstream}.git"
)
sha1sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%%-git}"
+ cd "${srcdir}/${_upstream}"
git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${srcdir}/${pkgname%%-git}"
- NOCONFIGURE=1 ./autogen.sh
-}
-
build() {
- cd "${srcdir}/${pkgname%%-git}"
- CPPFLAGS="$CPPFLAGS -I/usr/include/compiz \
- -I/usr/include/startup-notification-1.0 \
- -I/usr/include/libxml2" \
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd "${srcdir}/${_upstream}"
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
make
}
package() {
- cd "${srcdir}/${pkgname%%-git}"
+ cd "${srcdir}/${_upstream}"
make DESTDIR="${pkgdir}" install
}