summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrufo2018-11-11 23:17:34 +0000
committergrufo2018-11-11 23:17:34 +0000
commit200e4f757db7385963fd41a82e37ce09882ca169 (patch)
tree50b7eaaf5d7d56ce7945f148c70817d41efd3213 /PKGBUILD
parenteef6dec12fdf3982453bd4ba836385e9ff0685a4 (diff)
downloadaur-200e4f757db7385963fd41a82e37ce09882ca169.tar.gz
New git commit (r126.4e34376)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aae18ecb9d7c..54d7fd6e1525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: grufo <madmurphy333@gmail.com>
pkgname='libconfini-git'
-_pkgname='libconfini'
-pkgver='r125.8fe0464'
+_libname='libconfini'
+pkgver='r126.4e34376'
pkgrel=1
pkgdesc='Yet another INI parser'
arch=('i686' 'x86_64')
@@ -10,40 +10,40 @@ url='https://madmurphy.github.io/libconfini/'
license=('GPL')
provides=('libconfini')
conflicts=('libconfini')
-source=("git+https://github.com/madmurphy/${_pkgname}.git")
+source=("git+https://github.com/madmurphy/${_libname}.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${_libname}"
printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix=/usr
+ cd "${srcdir}/${_libname}"
+ ./autogen.sh --prefix=/usr CFLAGS='-pedantic -std=c99 -g -O2'
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_libname}"
make
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_libname}"
make check
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_libname}"
make DESTDIR="${pkgdir}" install
}