summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Poulet2018-05-27 22:50:05 +0200
committerArthur Poulet2018-05-27 22:50:05 +0200
commit697f58858d538f5c233debcd5e9f13f09ee52f0a (patch)
treea8b1e7ac2785d809bcea198399cbb9cac54d3219 /PKGBUILD
parent63f96b1d841c022434d331e7548025cf4ab7ce62 (diff)
downloadaur-697f58858d538f5c233debcd5e9f13f09ee52f0a.tar.gz
Improve the package (depends, building, version)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35db5bf2f506..7948930ab22d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
# Maintainer: Arthur Poulet (arthur.poulet@sceptique.eu)
pkgname=libcredid
-pkgver=v0.3.5.r0.02b654e
-pkgrel=1
+pkgver=0.3.5
+pkgrel=2
pkgdesc="C Binding for credid client"
arch=('any')
url="https://github.com/Credid/c-credid-api"
license=('GPLv3')
groups=()
depends=()
-makedepends=('cmake gcc')
+makedepends=('gcc make')
provides=()
conflicts=()
replaces=()
backup=()
options=()
install=
-source=('c-credid-api::git+https://github.com/Credid/c-credid-api')
-#source=('c-credid-api.tar.gz::http://localhost/transfer_more_pkg/c-credid-api.tar.xz')
+#source=('c-credid-api::git+https://github.com/Credid/c-credid-api')
+source=('libcredid-client.tar.gz::https://github.com/Credid/libcredid-client/archive/v0.3.5.tar.gz')
noextract=()
md5sums=('SKIP')
-pkgver() {
- cd "$srcdir/c-credid-api"
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
+#pkgver() {
+# cd "$srcdir/c-credid-api"
+# printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+#}
build() {
- cd "$srcdir/c-credid-api"
+ cd "$srcdir/libcredid-client-$pkgver"
make
}
package() {
- cd "$srcdir/c-credid-api"
+ cd "$srcdir/libcredid-client-$pkgver"
make PREFIX="$pkgdir/usr/local" install
}