summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2023-03-06 10:32:21 +0700
committerAchmad Fathoni2023-03-06 10:32:21 +0700
commit3a876637a5aabaa6b98a60acec94f2414b656a9b (patch)
tree4c1c905338483a08cfcfb06cb8c71f72afbf6987 /PKGBUILD
parent6ba9da8f8862971571dc9818b41b35499f5029d9 (diff)
downloadaur-3a876637a5aabaa6b98a60acec94f2414b656a9b.tar.gz
add fmt dep and fix warning as error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a2fea1428e1..be37d1d4cd78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ url="https://dartsim.github.io"
license=('BSD')
depends=('assimp' 'boost' 'eigen' 'fcl' 'libccd' 'bullet' 'coin-or-ipopt'
'nlopt' 'octomap' 'ode' 'openscenegraph' 'tinyxml2' 'urdfdom'
- 'glu' 'freeglut' 'libxi' 'libxmu' 'pagmo')
+ 'glu' 'freeglut' 'libxi' 'libxmu' 'pagmo' 'fmt')
optdepends=('pagmo: pagmo optimizer support')
makedepends=('cmake')
provides=('dartsim')
@@ -32,6 +32,7 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
+ -DDART_TREAT_WARNINGS_AS_ERRORS="off"
make
}