summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredtide2024-01-16 22:10:50 +0100
committerredtide2024-01-16 22:18:58 +0100
commit66e7b1d4ab610d04bc30fb8860a38cd6a10290ef (patch)
tree69f0df53a5349590e36ff33d8d209e35d56ef430 /PKGBUILD
downloadaur-66e7b1d4ab610d04bc30fb8860a38cd6a10290ef.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e579c831303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: redtide <redtid3@gmail.com>
+
+_pkgname=libdbusmenu-qtilities
+pkgbase=$_pkgname-git
+pkgname=(libdbusmenu-qtilities{5,6}-git)
+pkgver=r362.8dfc07e
+pkgrel=1
+pkgdesc="Qt implementation of the DBusMenu protocol"
+arch=(
+ i686
+ x86_64
+)
+url="https://github.com/qtilities/$_pkgname"
+license=(LGPL)
+makedepends=(
+ cmake
+ doxygen
+ git
+)
+source=(git+$url.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//; s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ for v in 5 6; do
+ cmake \
+ -B build$v \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=None \
+ -D PROJECT_QT_VERSION=$v \
+ -S "$srcdir/$_pkgname" \
+ -W no-dev
+ cmake --build build$v --verbose
+ done
+}
+
+package_libdbusmenu-qtilities5-git() {
+ depends=(qt5-base)
+ provides=($_pkgname5)
+ conflicts=($_pkgname5)
+ DESTDIR="$pkgdir" cmake --install build5
+}
+
+package_libdbusmenu-qtilities6-git() {
+ depends=(qt6-base)
+ provides=($_pkgname6)
+ conflicts=($_pkgname6)
+ DESTDIR="$pkgdir" cmake --install build6
+}