summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Radel2022-12-05 13:18:19 +0100
committerBenjamin Radel2022-12-05 13:18:54 +0100
commit4bc75bfa53148cdec9998db1b60f73d92c9c9e9c (patch)
tree82f1e63de46c90b5276b4c50c38fcf1a897c05a4 /PKGBUILD
parent4c7b9c4e99038ab19007940fb9c9af1d6f897f3b (diff)
downloadaur-4bc75bfa53148cdec9998db1b60f73d92c9c9e9c.tar.gz
Bump version to 1.8.34
- Add upstream fixes for openjpeg2.5, compile issues on Arch, remove support for openjpeg1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2b0fa2a87ca..b6bf39415e43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
# Maintainer: Benjamin Radel <aur@radel.tk>
# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
pkgname=libdcp
-pkgver=1.8.27
+pkgver=1.8.34
pkgrel=1
pkgdesc="A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files"
arch=('i686' 'x86_64')
url="https://carlh.net/libdcp"
license=('GPL')
-depends=('libxml++2.6' 'xmlsec' 'imagemagick' 'openjpeg2>=2.5' 'libcxml>=0.17.3' 'libsigc++>=2.0' 'boost-libs>=1.72.0' 'libasdcp-cth>=0.1.6.r18.ga276ed1')
+depends=('libxml++2.6' 'xmlsec' 'imagemagick' 'openjpeg2>=2.5' 'libcxml>=0.17.4' 'libsigc++>=2.0' 'boost-libs>=1.72.0' 'xerces-c' 'libasdcp-cth>=0.1.6.r20.g825e475')
makedepends=('git' 'python' 'boost>=1.72.0' 'gcc' 'pkg-config')
-source=("${pkgname}-${pkgver}.tar.gz::https://git.carlh.net/gitweb/?p=${pkgname}.git;a=snapshot;h=v${pkgver};sf=tgz"
- "0001-fix-compile-with-openjp25.patch")
-sha256sums=('a51dd14d864fd5356a16b6e43542ef1ef5aced5d2d55ff5b2bcb751ddd170c7c'
- '671046a87eaf567ca94cde72a92497239155d7cb12450ee12b41b2eed13c78fb')
+_cherrypicks=('32360aedc97a0cc9acc1b1c10d2e8351dcacb549'
+ 'b995947a86a583a44bbe667e9bbd031296bf7e88'
+ '2c6d80c295dd3d10c1c9c08dd31758dd1abdf5da')
+source=("${pkgname}-${pkgver}::git+git://git.carlh.net/git/${pkgname}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
prepare() {
- mv "${srcdir}/${pkgname}-v${pkgver}-"* "${srcdir}/${pkgname}-${pkgver}"
cd $srcdir/${pkgname}-${pkgver}
- ### Patch libdcp for openjpeg>2.5 ###
+ ### Cherry pick upstream commits (fixes and such) ###
+ for c in "${_cherrypicks[@]}"; do
+ echo "Applying commit ${c}"
+ git cherry-pick ${c};
+ done
+ ### Apply patches ###
for p in "${source[@]}"; do
if [[ "$p" =~ \.patch$ ]]; then
echo "Applying patch ${p##*/}"