summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:42:17 +0200
committerDaniel Nagy2015-06-08 19:42:17 +0200
commit0f72e8a1b41cfc03566e348f25be3a26311aaf28 (patch)
tree3de9d69994be26dbf0204bcff38a4e9779565b79 /PKGBUILD
downloadaur-0f72e8a1b41cfc03566e348f25be3a26311aaf28.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22bbef082796
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=libde265-git
+_gitname=libde265
+pkgver=v0.1.1087.ga0c81b6
+pkgrel=1
+pkgdesc="Open h.265 video codec implementation"
+arch=('i686' 'x86_64')
+url="https://github.com/strukturag/libde265"
+license=('LGPL3')
+depends=( "glibc" )
+makedepends=( 'git')
+conflicts=( "$_gitname" )
+provides=( "$_gitname" )
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# 'pacman41' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=( "$_gitname::git+$url" )
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ find "$pkgdir" -name "*.la" -delete
+}