summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-02-15 00:37:57 +0200
committerAdrian Perez de Castro2020-02-15 00:37:57 +0200
commit5194f2bb6a05fc78d6db4afe493d3a4085b8a8b6 (patch)
treeec730c7c3543a46d3d48d46cd9e4d36579f95f9c /PKGBUILD
parente00e4f8069e31b41bc5da40d9c95456d2d654127 (diff)
downloadaur-5194f2bb6a05fc78d6db4afe493d3a4085b8a8b6.tar.gz
Use the -H/-B options to CMake to set srcdir/buildir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a04c1a998efd..4678d80e830d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=libdispatch
pkgver=5.1.4
-pkgrel=1
+pkgrel=2
pkgdesc='Comprehensive support for concurrent code execution on multicore hardware'
arch=(i686 x86_64 arm armv6h armv7h aarch64)
url=https://apple.github.io/swift-corelibs-libdispatch
@@ -20,22 +20,19 @@ prepare () {
}
build () {
- rm -rf _build
- mkdir _build
- cd _build
- CC=clang CXX=clang++ cmake \
+ CC=clang CXX=clang++ cmake -H"${pkgname}" -Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBlocksRuntime_INCLUDE_DIR=/usr/include \
-DBlocksRuntime_LIBRARIES=/usr/lib/libBlocksRuntime.so \
"../${pkgname}"
- cmake --build . -j $(nproc)
+ cmake --build build -j $(nproc)
}
check () {
- cmake --build _build --target test
+ cmake --build build --target test
}
package () {
- DESTDIR="${pkgdir}" cmake --install _build
+ DESTDIR="${pkgdir}" cmake --install build
}