summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-05-01 10:34:26 +0800
committerChocobo12019-05-01 10:58:59 +0800
commitd98dd967e79e8983f80a5a5399d09fc32b77e294 (patch)
tree58afc206ab9b69fd508c5ab97babaeefa2c877d8 /PKGBUILD
downloadaur-d98dd967e79e8983f80a5a5399d09fc32b77e294.tar.gz
newpkg: libdnet-git 1.12.r20.g54a0c14-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae64ee8a69f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libdnet-git
+pkgver=1.12.r20.g54a0c14
+pkgrel=1
+pkgdesc="A simplified, portable interface to several low-level networking routines"
+arch=('i686' 'x86_64')
+url="https://github.com/dugsong/libdnet"
+license=('BSD')
+depends=('glibc' 'sh')
+makedepends=('git')
+provides=('libdnet')
+conflicts=('libdnet')
+options=('staticlibs')
+source=("git+https://github.com/dugsong/libdnet.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libdnet"
+
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/libdnet-//p}')
+ _rev=$(git rev-list --count libdnet-$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+}
+
+build() {
+ cd "libdnet"
+
+ autoconf
+ ./configure \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --mandir="/usr/share/man"
+ make
+}
+
+package() {
+ cd "libdnet"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libdnet/LICENSE"
+}