summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-11-12 21:35:18 +0800
committerChocobo12019-11-12 21:35:18 +0800
commitac2593f52fb48e9c4fd13059c102b4c40f7937a4 (patch)
treebbc9f676e926dbb23adf5049040906c3005a6bfc /PKGBUILD
downloadaur-ac2593f52fb48e9c4fd13059c102b4c40f7937a4.tar.gz
newpkg: libebur128-git 1.2.4.r43.g68abf1b-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c18b7a6eb8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libebur128-git
+pkgver=1.2.4.r43.g68abf1b
+pkgrel=1
+pkgdesc="A library implementing the EBU R128 loudness standard"
+arch=('i686' 'x86_64')
+url="https://github.com/jiixyj/libebur128"
+license=('MIT')
+depends=('glibc')
+makedepends=('git' 'cmake')
+provides=('libebur128')
+conflicts=('libebur128')
+options=('staticlibs')
+source=("git+https://github.com/jiixyj/libebur128.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libebur128"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libebur128"
+
+ mkdir -p "_build" && cd "_build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ "../"
+ make
+}
+
+package() {
+ cd "libebur128"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libebur128"
+}