summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-29 15:11:17 +0000
committerDaniel Bermond2018-04-29 15:37:17 +0000
commit004aacbee40c7d11270d0941b4afdababf39eece (patch)
treed016bf1f178ea8e4d199699427d8e9c20221baef /PKGBUILD
parent20588d3a63aa0e193cc5432c56ea584bf75f0230 (diff)
downloadaur-004aacbee40c7d11270d0941b4afdababf39eece.tar.gz
Fix license. Cosmetic changes.
printemf binary executable (src/printemf.c) is licensed under the GPL. libEMF (libemf/libemf.{c,h}) and header files are licensed under the LGPL. The license statements in the source files contains the 'any later version' statement, meaning that it's not restricted to GPL2 and LGPL2.1, but it can be modified and/or redistributed under later license versions like GPL3 and LGPL3.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3620fc2f9242..9e76f5503fca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,31 @@
pkgname=libemf
pkgver=1.0.9
-pkgrel=1
-pkgdesc="Library implementation of ECMA-234 API for the generation of enhanced metafiles."
+pkgrel=2
+pkgdesc='Library implementation of ECMA-234 API for the generation of enhanced metafiles'
arch=('i686' 'x86_64')
-url="http://libemf.sourceforge.net/"
-license=('LGPL2.1')
+url='http://libemf.sourceforge.net/'
+license=('GPL' 'LGPL')
provides=('libEMF.so')
source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('dcc1f7dc09597a7e20fa808fbef03f0c5cbdd99d65a4fddd981d7f1dd6e28b81')
build() {
cd "${pkgname}-${pkgver}"
+
./configure \
- --prefix=/usr \
- --enable-static=no \
- --enable-shared=yes \
+ --prefix='/usr' \
+ --enable-static='no' \
+ --enable-shared='yes' \
--enable-fast-install \
--enable-threads \
--enable-editing
+
make
}
package() {
cd "${pkgname}-${pkgver}"
+
make DESTDIR="$pkgdir" install
}