summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2015-10-23 22:35:50 +0200
committerFrederik “Freso” S. Olesen2015-10-23 22:35:50 +0200
commit4d7f34dd2fec1d58f52bd2400c7b2f1301666b8a (patch)
tree15c92b49a892acb42fd1513485780f094bc07a32 /PKGBUILD
downloadaur-4d7f34dd2fec1d58f52bd2400c7b2f1301666b8a.tar.gz
libespm-git r207.fe6b7b8-1
This is the initial PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c63aaa281e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
+_pkgname=libespm
+pkgname=$_pkgname-git
+pkgver=r207.fe6b7b8
+pkgrel=1
+pkgdesc='Library for reading and writing .esp and .esm plugin files.'
+arch=('any')
+url="https://github.com/WrinklyNinja/$_pkgname"
+license=('GPL3')
+depends=('boost-libs')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ git checkout-index -a --prefix="$pkgdir/usr/include/$_pkgname/"
+}