summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjosephriches@gmail.com2016-11-04 14:29:56 +0000
committerjosephriches@gmail.com2016-11-04 14:29:56 +0000
commit56b362694a9d2f16ba7868d011b6dd52504fab14 (patch)
treedd79f3b38a51ba9cc5f7e957445d844a72ac19ec /PKGBUILD
parent3c667f8293cf5b0c826d880062238820ca38c8fe (diff)
downloadaur-56b362694a9d2f16ba7868d011b6dd52504fab14.tar.gz
libevdevc: switch source to galliumOS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 27 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c32764f03664..7969a21ef093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
+<<<<<<< HEAD
pkgname=libevdevc-git
+=======
+# Maintained by Joseph Riches
+
+pkgname=libevdevc
+>>>>>>> 18d5502329cdf2ab75d81e9ad9e4210ed6be2e50
pkgdesc="Chromium OS libevdev"
pkgver=2.0
pkgrel=1
arch=(i686 x86_64)
-url="https://github.com/hugegreenbug/libevdevc"
+<<<<<<< HEAD
+url="https://github.com/galliumos/libevdevc"
license=('custom:chromiumos')
_gitname='libevdevc'
depends=('glibc')
makedepends=('git' 'python2' 'check' 'valgrind' 'doxygen')
conflicts=('libevdevc')
-source=("$_gitname::git+https://github.com/hugegreenbug/libevdevc.git")
+source=("$_gitname::git+https://github.com/galliumos/libevdevc.git")
md5sums=('SKIP')
@@ -26,4 +33,22 @@ check() {
package() {
make -C "$srcdir/$_gitname" DESTDIR="${pkgdir}" install
+=======
+url="https://github.com/hugegreenbug/libevdevc"
+license=('custom:chromiumos')
+depends=('glibc')
+options=('!emptydirs' '!strip')
+
+source=('ChromiumOS_Licence.txt')
+source_x86_64=("${pkgname}_${pkgver}-ubuntu4_amd64.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/${pkgname}_${pkgver}-ubuntu4_amd64.deb")
+source_i686=("${pkgname}_${pkgver}-ubuntu4_i386.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/${pkgname}_${pkgver}-ubuntu4_i386.deb")
+
+md5sums=('af314be4bf04a749665a07203b120f54')
+md5sums_x86_64=('f76beab95337525666e03789bd250c24')
+md5sums_i686=('287715207a88d3f213a80d15332133a6')
+
+package() {
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+ install -Dm644 ChromiumOS_Licence.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENCE
+>>>>>>> 18d5502329cdf2ab75d81e9ad9e4210ed6be2e50
}