diff options
author | FabioLolix | 2024-05-01 14:27:15 +0200 |
---|---|---|
committer | FabioLolix | 2024-05-01 14:27:15 +0200 |
commit | 622ee168fe660039c9770876e148cc583eedfc48 (patch) | |
tree | 23200ff79aee524aa486a85164e3273bd13242f8 /PKGBUILD | |
parent | d67ab979e5ee906f0540e2e70a2404936dd3dcc2 (diff) | |
download | aur-622ee168fe660039c9770876e148cc583eedfc48.tar.gz |
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 50 |
1 files changed, 24 insertions, 26 deletions
@@ -1,35 +1,33 @@ -# Maintainer: Jaryl Chng <mrciku@gmail.com> +# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix +# Contributor: Jaryl Chng <mrciku@gmail.com> + pkgname=libewf-git -pkgver=20161109.11a3f476 +pkgver=20231119.r3.gf5aa2e2 pkgrel=1 -pkgdesc='Library to access the Expert Witness Compression Format (EWF)' -arch=('any') -url='https://github.com/libyal/libewf' -license=('LGPL') -provides=('libewf-git') -conflicts=('libewf') -groups=() -depends=() -makedepends=('git' 'autoconf' 'automake' 'libtool' 'gettext' 'pkg-config' 'bison' 'flex') -optdepends=() -options=() -source=('git+https://github.com/libyal/libewf.git') -sha1sums=('SKIP') - -_gitname="libewf" +pkgdesc="Library to access the Expert Witness Compression Format (EWF)" +arch=(x86_64) +url="https://github.com/libyal/libewf" +license=(LGPL) +depends=(bzip2 fuse2 openssl zlib glibc) +makedepends=(git) +provides=(libewf) +conflicts=(libewf) +source=("git+https://github.com/libyal/libewf.git") +sha256sums=('SKIP') pkgver() { - cd "$srcdir/$_gitname" - git log -1 --format='%cd.%h' --date=short | tr -d - + cd "libewf" + git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } -build() { - cd "$_gitname" - +prepare() { + cd "libewf" ./synclibs.sh - sed -i '/ewftools/d' Makefile.am - sed -i '/ewftools/d' configure.ac ./autogen.sh +} + +build() { + cd "libewf" ./configure \ --prefix=/usr \ --sysconfdir=/etc @@ -38,6 +36,6 @@ build() { } package() { - cd "$_gitname" + cd "libewf" make DESTDIR="$pkgdir/" install -}
\ No newline at end of file +} |