summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:19:04 +0100
committerBartłomiej Piotrowski2018-01-07 13:19:04 +0100
commit044d8d7103942eb2f662d48d8f9ae57fdf2bd63c (patch)
tree0a2622dbed09a7561dea1e65b20a31955d360ea7 /PKGBUILD
downloadaur-044d8d7103942eb2f662d48d8f9ae57fdf2bd63c.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9ba4e887f73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+
+pkgname=libexosip2
+epoch=1
+pkgver=5.0.0
+pkgrel=2
+pkgdesc="A library that hides the complexity of using SIP for multimedia session establishement"
+arch=('x86_64')
+url="https://savannah.nongnu.org/projects/exosip/"
+license=('GPL')
+depends=('libosip2>=4.0.0' 'openssl')
+validpgpkeys=('34C3985D068879312FE23C8BB5902A3AD90A5421')
+source=(https://download.savannah.gnu.org/releases/exosip/libexosip2-$pkgver.tar.gz{,.sig}
+ openssl110.patch)
+sha256sums=('a26558594de95405d3adeee554a7c10cb3ec5a9316a879e679b53a99a9cf2e1f'
+ 'SKIP'
+ 'e60ef8fe99e7aa8641398a70708ab1e4f85d04872f1c658949afc4fd657c4d5a')
+
+prepare() {
+ cd "$srcdir/libexosip2-${pkgver}"
+ patch -Np1 -i ../openssl110.patch
+}
+
+build() {
+ cd "$srcdir/libexosip2-${pkgver}"
+ ./configure --prefix=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "$srcdir/libexosip2-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}