summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2014-02-07 18:27:31 +0100
committerCarsten Teibes2014-02-07 18:27:31 +0100
commit89decfd94d63b439031d5ced2b3b7f0940578613 (patch)
treedb7341e93065bc74d3c0e6754fd83c063330d9c4 /PKGBUILD
downloadaur-89decfd94d63b439031d5ced2b3b7f0940578613.tar.gz
[add] libfat-ogc 1.0.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78a647a9cbf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Aaron Lindsay <aaron@aaronlindsay.com>
+# Contributor: Tiago Camargo <tcamargo@gmail.com>
+
+pkgname=libfat-ogc
+pkgver=1.0.11
+pkgrel=1
+pkgdesc="Library for acessing FAT filesystems from Nintendo Gamecube/Wii homebrew"
+arch=('any')
+url="http://www.devkitpro.org/"
+license=('custom')
+options=(!strip staticlibs)
+depends=('devkitppc' 'libogc')
+conflicts=('libfat-ogc-svn') # this is a hack to support transition, can be removed later
+source=("http://downloads.sourceforge.net/sourceforge/devkitpro/libfat-src-$pkgver.tar.bz2")
+sha256sums=('ded1a18f4b3baea1fdba3868fd79cf0189c57f3697099b9ea4727cbd1a519ae0')
+
+build() {
+ source /etc/profile.d/devkitppc.sh
+
+ make ogc-release
+}
+
+package() {
+ export DEVKITPRO="$pkgdir"/opt/devkitpro
+
+ install -d "$DEVKITPRO"/libogc/{lib/{cube,wii},include}
+ make ogc-install
+ # license
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ head -n 30 include/fat.h > "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+}