summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorayekat2019-07-15 08:18:47 +0200
committerayekat2019-07-15 08:44:10 +0200
commit9ffee17e8c86d54606d967f8c76ce3c8bbdc9afd (patch)
tree8f004dce16745c64cadebcc2c8d9286c82de8052 /PKGBUILD
parentc6221527ccf84b17db817631f6af7429af78b736 (diff)
downloadaur-9ffee17e8c86d54606d967f8c76ce3c8bbdc9afd.tar.gz
Add patch for fixing header files
C treats an argument list like `()` as "variable number of arguments", whereas for simply "no argument", one needs `(void)`. The header files thus cause all sorts of issues if unpatched. This should probably be taken to upstream.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b88aca023535..29e29b1e6d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,12 @@ conflicts=(libfiber)
source=('git+https://github.com/brianwatling/libfiber'
'0002-dist-libev.diff'
'0003-no-work-stealing.diff'
+ '0004-fix-void-args.diff'
'libfiber.pc')
sha256sums=(SKIP
e36b02fc439e1185a734db2a312a4650e803acb3eeef1105e40ffdc65726ae5d
88ac1ea4517e6d73a571d243ffd51711a2e4ba2c45b92136968489f9c1979b62
+ e6cabc2f4a41bdf6385f9c1e57213913f2a2706967ec74d0a75d0df5fe94c9c7
eb8f429c6705a23aec697990271e724541815d8b43aafcb36d21fd7186dacacd)
pkgver() {
@@ -37,6 +39,9 @@ prepare() {
# Use downstream (distribution) libev:
patch -p1 -i "$srcdir"/0002-dist-libev.diff
+ # Fix void arguments in header files:
+ patch -p1 -i "$srcdir"/0004-fix-void-args.diff
+
# Don't use work stealing:
# NOTE: This is disabled by default, as it deviates from vanilla upstream;
# apply if you run into issues with fibers being scheduled in an awkward way.