summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse R Codling2022-04-18 16:33:04 -0400
committerJesse R Codling2022-04-18 16:33:04 -0400
commitba9b355b3df249737999c8a1fac0f22ae557a85f (patch)
tree87c9f4eba17ad9b9e50d00876b46d80b383212d1 /PKGBUILD
parentef4310b8b0b428591b279e126d2ab0b1889defb9 (diff)
downloadaur-ba9b355b3df249737999c8a1fac0f22ae557a85f.tar.gz
Include tests and possible SSE vectorizations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 34 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87e8cacb4042..952de097ee5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Jesse R Codling (jclds139) jclds139 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=libflame-git
-pkgver=r78.b0936fbe
-pkgrel=2
+pkgver=r87.b112dd8f
+pkgrel=1
pkgdesc="High-performance object-based library for DLA computations"
arch=('i686' 'x86_64')
license=('BSD')
@@ -21,14 +22,42 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "${pkgname}"
+ if [ `grep -c sse /proc/cpuinfo` -eq `nproc`]; then
+ ENABLE_SSE=--enable-vector-intrinsics=sse
+ fi
+
# static build is necessary for some packages and programs (e. g. GAMESS)
- ./configure --prefix=/usr --enable-static-build --enable-dynamic-build --enable-multithreading=openmp --enable-supermatrix --enable-lapack2flame --enable-max-arg-list-hack
+ ./configure --prefix=/usr --enable-static-build --enable-dynamic-build $ENABLE_SSE --enable-multithreading=openmp --enable-supermatrix --enable-lapack2flame --enable-max-arg-list-hack
+}
+
+build() {
+ cd "${pkgname}"
+
make
}
+check() {
+ cd "${pkgname}/test"
+
+ sed -i 's/^LIBLAPACK\s\+:=/#\0/' Makefile
+ # disable external LAPACK in tests (not enabled in build())
+ sed -i 's|^\(LIBBLAS\s\+:=\).*|\1 /usr/lib/libblas.so|' Makefile
+
+ sed -i 's/0\(.*FLA \)/1\1/' input.global.operations
+ # enable all libFlame (but not FLASH) tests
+ sed -i 's/^i\(\s\+ Reaction to test failure\)/a\1/' input.global.general
+ # abort on any test failure
+
+ mkdir obj
+ make
+ ./test_libflame.x
+
+
+}
+
package() {
cd "${pkgname}"