summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse R Codling2022-06-07 23:51:16 -0400
committerJesse R Codling2022-06-07 23:51:16 -0400
commitc5e8fc9404f80506e2c5813688e75fcd3f0417dd (patch)
tree5237b7be3bbdc6f2c8ec310e7edb6a029bad00d1 /PKGBUILD
parentba9b355b3df249737999c8a1fac0f22ae557a85f (diff)
downloadaur-c5e8fc9404f80506e2c5813688e75fcd3f0417dd.tar.gz
Take out static build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 952de097ee5c..0000e6411fba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=libflame-git
-pkgver=r87.b112dd8f
+pkgver=r90.9fdb4fd1
pkgrel=1
pkgdesc="High-performance object-based library for DLA computations"
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ provides=('libflame')
conflicts=('libflame')
source=("$pkgname::git+https://github.com/flame/libflame.git")
sha1sums=('SKIP')
-options=('staticlibs')
+# options=('staticlibs')
pkgver() {
cd "${pkgname}"
@@ -29,8 +29,8 @@ prepare() {
ENABLE_SSE=--enable-vector-intrinsics=sse
fi
- # static build is necessary for some packages and programs (e. g. GAMESS)
- ./configure --prefix=/usr --enable-static-build --enable-dynamic-build $ENABLE_SSE --enable-multithreading=openmp --enable-supermatrix --enable-lapack2flame --enable-max-arg-list-hack
+ # static build is only needed in some cases. We can make a separate -static package if needed
+ ./configure --prefix=/usr --enable-dynamic-build $ENABLE_SSE --enable-multithreading=openmp --enable-supermatrix --enable-lapack2flame --enable-max-arg-list-hack --enable-gpu
}
build() {