summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2016-07-11 00:28:54 +0200
committerPeter Mattern2016-07-11 00:28:54 +0200
commit906386c4c11147b9b40f6e7394db44004812a798 (patch)
tree6610552e2eed839282714743c2de98226741686c /PKGBUILD
parent3d1cb68dc21d6b34c9d55f39bebbb22828d19b9b (diff)
downloadaur-906386c4c11147b9b40f6e7394db44004812a798.tar.gz
Conflict with PCManFM-Qt ≤ 0.10.0
which was still including the library itself
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c113393d4b60..4ca681f231ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libfm-qt
pkgname=$_pkgname-git
-pkgver=r301.f0f38ac
+pkgver=0.11.0.13.g4aa2bb6
pkgrel=1
pkgdesc='Qt port of libfm, a library providing components to build desktop file managers'
arch=('i686' 'x86_64')
@@ -11,13 +11,13 @@ license=('LGPL')
depends=('qt5-x11extras' 'libfm>=1.2.0')
makedepends=('cmake' 'qt5-tools')
provides=("$_pkgname")
-conflicts=("$_pkgname")
+conflicts=("$_pkgname" 'pcmanfm-qt<=0.10.0')
source=('git+https://github.com/lxde/libfm-qt.git')
sha256sums=("SKIP")
pkgver() {
cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --always | sed 's:-:.:g'
}
build() {