summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Gottula2020-10-24 17:44:34 -0700
committerJustin Gottula2020-10-24 17:59:13 -0700
commitcf00c3f3f3246135635710b287731c744f218d58 (patch)
tree20e7d2b804177208168d24181773185e4f869b11 /PKGBUILD
parent789c572e51010dd278cb3e8657e41ab3ebd35464 (diff)
downloadaur-cf00c3f3f3246135635710b287731c744f218d58.tar.gz
Remove broken dependency on libusbx
The most recent package release of libusb, 1.0.23-3, removed the 'libusbx=1.0.23' provides directive. That broke the 'libusbx>=1.0.8' dependency in this package. It actually turns out that libftd2xx has been statically linked to its own internal copy of libusb for a VERY LONG time, judging by the release-notes.txt file: the notes for version 0.4.0 (!) specifically mention switching to "static linkage to libusb to avoid installation issues." I checked both the dynamic libftd2xx.so file and the static libftd2xx.a file and confirmed that both library variants do not have any external dependency on libusb; all of the required libusb symbols are contained within the libftd2xx library files themselves. Incidentally, the libusbx dependency in the PKGBUILD, removed in this commit, suggested a minimum required libusb version of 1.0.8. Meanwhile, the included copy of libusb is version 1.0.20. So it's entirely possible that, even IF the premise that an external libusb was needed was correct, that the version asked for as a dependency may have not even been sufficient.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcdda3fc5b40..b7347e8c7c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Maintainer: Chris <alostengineer at narmos org>
# Contributor: Olivier EBLE <olivier.eble at gmail com>
# Contributor: Laszlo Papp <djszapi2 at gmail com>
+# Contributor: Justin Gottula <justin at jgottula com>
pkgname=libftd2xx
pkgver=1.4.8
-pkgrel=2
+pkgrel=3
pkgdesc="Library that allows a direct access to a USB FTDI2XX chip based device"
arch=('i686' 'x86_64')
url="http://www.ftdichip.com/"
license=('Proprietary')
-depends=('glibc' 'libusbx>=1.0.8')
+depends=('glibc')
source=(
55-ft2232.rules