summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2019-01-04 08:13:32 -0200
committerLucas Heitzmann Gabrielli2019-01-04 08:13:32 -0200
commit8d75fc67a5ee49d0f0a62372582a3c0593a7094c (patch)
tree2f13270b1d72ab40cb258c0fe7d58d09ec28b51c /PKGBUILD
downloadaur-8d75fc67a5ee49d0f0a62372582a3c0593a7094c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f791503ce81a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+
+pkgname=libgdsii-git
+pkgdesc='C++ library for working with GDSII binary data files'
+pkgver=20181030
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/HomerReid/libGDSII"
+license=('GPL2')
+depends=('gcc-libs')
+optdepends=()
+makedepends=('git')
+options=(!emptydirs)
+source=('libgdsii::git+https://github.com/HomerReid/libGDSII')
+md5sums=('SKIP')
+
+pkgver() {
+ cd libgdsii
+ git log --format="%cd" --date=short -1 | sed 's/-//g'
+}
+
+build() {
+ cd libgdsii
+ sh autogen.sh --prefix='/usr'
+}
+
+package() {
+ cd libgdsii
+ make install DESTDIR="${pkgdir}"
+}
+
+# vim: fileencoding=utf-8 spelllang=en shiftwidth=2 expandtab