summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit6c52a743c360b7814da7c637e77df5a1b94528cf (patch)
treec5b35c2f7f55f5aab00018801d851f39db663487 /PKGBUILD
downloadaur-6c52a743c360b7814da7c637e77df5a1b94528cf.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..161f1b3be2aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Dragonlord <archlinux[at]dragonlord[.]cz>
+
+pkgname=libghttp
+pkgver=1.0.9
+pkgrel=3
+pkgdesc="HTTP protocol client library."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+source=(ftp://ftp.gnome.org/pub/gnome/sources/$pkgname/1.0/$pkgname-$pkgver.tar.gz)
+url="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.0"
+
+md5sums=('0690e7456f9a15c635f240f3d6d5dab2')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ if [[ "$CARCH" == "x86_64" ]]; then
+ ./configure --prefix=/usr --host=i686-pc-linux-gnu
+ else
+ ./configure --prefix=/usr
+ fi
+
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}