summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Barnett2015-06-09 18:22:59 -0500
committerJames Barnett2015-06-09 18:22:59 -0500
commit33bcc5076664c515d8661d89f9932a6c0cc95624 (patch)
tree1c0900817d12e3633b420da4af04d5747c65dbf9 /PKGBUILD
downloadaur-33bcc5076664c515d8661d89f9932a6c0cc95624.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9adcfcf984e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: James W. Barnett <jbarnet4 at tulane dot edu>
+pkgname=libgmxcpp
+pkgver=3.2
+pkgrel=1
+pkgdesc="A library for use in analyzing GROMACS simulation output files"
+arch=(any)
+url="https://github.com/wesbarnett/libgmxcpp"
+license=('GPL','LGPL')
+makedepends=('cmake')
+source=(${url}/archive/v${pkgver}.tar.gz)
+md5sums=('a482632b75164730debbd5b1799acc22')
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "$pkgname-$pkgver"/build
+ make DESTDIR="$pkgdir/" install
+}