summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIru Cai2020-06-20 11:44:41 +0800
committerIru Cai2020-06-20 11:44:41 +0800
commit8f618ac4e3c06c014df2cc123fa3b4379f39abc8 (patch)
treed08f4e3aa52eef10db6e7760c39ac1253e5be71a /PKGBUILD
parent000fba856df5e484686e4ab2c6e74a9a1ae3b3a6 (diff)
downloadaur-8f618ac4e3c06c014df2cc123fa3b4379f39abc8.tar.gz
remove arch flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dee3a588ac88..564bc9241e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,22 @@
pkgname='libgoldilocks-git'
_pkgname='libgoldilocks'
-pkgver=644.045bec4
+pkgver=727.d07cb5b
pkgrel=1
pkgdesc="An implementation of Mike Hamburg's Ed448 (Goldilocks) curve"
arch=('i686' 'x86_64')
url='https://github.com/otrv4/libgoldilocks'
license=('MIT')
depends=()
-source=('git+https://github.com/otrv4/libgoldilocks.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/otrv4/libgoldilocks.git'
+ 'remove_archflags.patch')
+sha256sums=('SKIP'
+ '0a1e262dd29db8ffc3fe7b41f35b9fc4f0d417d5da83557da7f5aa9ed9c00a04')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i "${srcdir}/remove_archflags.patch"
+}
build() {
cd "${srcdir}/${_pkgname}"