summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreg Erwin2022-11-26 02:15:52 -0800
committerGreg Erwin2022-11-26 02:15:52 -0800
commit225c212ad72f168ddde537fca78937f1d1bd7c7b (patch)
tree772bc4774fa6e9ec07dc1fba4a05784b9a271322 /PKGBUILD
parent799f17a008db8399e896a26b73aaf3049ec5ab50 (diff)
downloadaur-225c212ad72f168ddde537fca78937f1d1bd7c7b.tar.gz
Workaround python bindings packaging issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cff29913bc09..d820fa72af45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Greg Erwin <first name last name 256 at gmail dot com>
pkgname=libgpiod-git
-pkgver=r872.0149e69
+pkgver=r983.03a6c2f
pkgrel=1
pkgdesc="C library and tools for interacting with the linux GPIO character device"
url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('LGPL2.1')
-depends=('linux-api-headers>=5.5' 'python')
+depends=('linux-api-headers>=5.5')
conflicts=('libgpiod')
provides=('libgpiod')
-makedepends=('git' 'autoconf-archive' 'help2man')
+makedepends=('git' 'autoconf-archive' 'help2man' 'python-setuptools')
source=('git://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git')
sha1sums=('SKIP')
@@ -31,5 +31,6 @@ build() {
package() {
cd "${pkgname%-git}"
+ sed -i s,--prefix='$(prefix)',--root="$pkgdir", bindings/python/Makefile.am
make DESTDIR="$pkgdir/" install
}