summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorignapk2021-01-15 02:07:26 +0100
committerignapk2021-01-15 02:07:26 +0100
commit5089d9b3a7e38f2c1b918e974078f7a8b8776ce8 (patch)
tree7557a724be6f79eb1dba976f3eeb3e9a6db23159 /PKGBUILD
downloadaur-5089d9b3a7e38f2c1b918e974078f7a8b8776ce8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4afd4cc801b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
+
+pkgname=libgweather-git
+_pkgname=libgweather
+pkgver=40.alpha.r7.g21e87d8f
+pkgrel=1
+pkgdesc="Location and timezone database and weather-lookup library"
+url="https://wiki.gnome.org/Projects/LibGWeather"
+arch=(x86_64)
+license=(LGPL)
+depends=(libsoup gtk3 geocode-glib dconf)
+makedepends=(gobject-introspection vala git gtk-doc glade meson)
+provides=(libgweather-3.so libgweather)
+conflicts=(libgweather)
+source=("git+https://gitlab.gnome.org/GNOME/libgweather.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ meson compile -C build
+}
+
+check() {
+ # Test fails without fr_FR.UTF-8 locale
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}