summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2024-01-01 17:18:38 -0500
committerChris Severance2024-01-01 17:18:38 -0500
commit78651c6181b4886b30cbbad713f99e35ed3ba43a (patch)
treecfef70482ed9ada1fe9aa5ebb4dd5f97f28e2dba /PKGBUILD
parent059fea562c8c41393272c7ffbe364524e7dff2b8 (diff)
downloadaur-libgxps-git.tar.gz
autu: Update to 0.3.2.r6.g665dc29-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 49 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f4eeb66bd8a..d3996b30d370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,80 @@
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
-# Contributor: Jan de Groot https://www.archlinux.org/packages/extra/x86_64/libgxps/
-# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
set -u
-_pkgname='libgxps'
-pkgname='libgxps-git'
-pkgver=0.3.0.r0.g762b302
+pkgname=libgxps
+pkgname+='-git'
+pkgver=0.3.2.r6.g665dc29
pkgrel=1
-pkgdesc='An XPS Documents library'
-arch=('i686' 'x86_64')
-url="https://git.gnome.org/browse/${_pkgname}/"
-license=('GPL')
-depends=('gtk3' 'libarchive' 'libjpeg-turbo' 'libtiff' 'lcms2' 'glib2' 'openssl-1.0')
-makedepends=('gobject-introspection' 'gtk-doc' 'git' 'meson' 'gnome-common')
-provides=("${_pkgname}=${pkgver%.r*}")
-conflicts=("${_pkgname}")
-_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
-source=("git://git.gnome.org/${_pkgname}")
+pkgdesc="XPS Documents library"
+url="https://wiki.gnome.org/Projects/libgxps"
+arch=(x86_64)
+arch+=('i686')
+license=(GPL2)
+depends=(
+ cairo
+ freetype2
+ glib2
+ lcms2
+ libarchive
+ libjpeg-turbo
+ libpng
+ libtiff
+)
+makedepends=(
+ git
+ gobject-introspection
+ gtk-doc
+ gtk3
+ meson
+)
+provides=("${pkgname%-git}=${pkgver%.r*}")
+conflicts=("${pkgname%-git}")
+#_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
+_srcdir="${pkgname%-git}"
+source=("git+https://gitlab.gnome.org/GNOME/libgxps.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
set -u
- cd "${_pkgname}"
- git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+ cd "${_srcdir}"
+ git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/' -e 's/-/./g' #-e 's/v//'
set +u
}
prepare() {
set -u
- mkdir 'build'
- cd "${_pkgname}"
+ cd "${_srcdir}"
set +u
}
build() {
set -u
- cd 'build'
- if [ ! -s 'config.h' ]; then
- meson --prefix='/usr' --buildtype='release' "../${_pkgname}" -Denable-gtk-doc='true' -Denable-man='true'
- fi
- ninja
+ local meson_options=(
+ -D enable-man=true
+ -D enable-gtk-doc=true
+ )
+
+ arch-meson libgxps build "${meson_options[@]}"
+ meson compile -C build
set +u
}
check() {
set -u
- cd 'build'
- meson test
+ meson test -C build --print-errorlogs
set +u
}
package() {
set -u
- cd 'build'
- DESTDIR="${pkgdir}" ninja install
+ meson install -C build --destdir "$pkgdir"
set +u
}
set +u
+
+# vim:set sw=2 sts=-1 et: