summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlyxia Sother2024-02-05 20:23:19 +0100
committerAlyxia Sother2024-02-05 20:23:34 +0100
commit98f2c7a08655e2169e241cd9cdc270197b66cfba (patch)
tree560aa0315c8c12e2cba88b67645c280218eb5264 /PKGBUILD
parente187372658249fb9e18c9cede03d29809e629df4 (diff)
downloadaur-libhelium.tar.gz
Update to v1.8.10, fix schema compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2466f0739b61..4cb247c32247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alyxia Sother <nylkvn@evfrhc.arg(rot13)>
pkgname=libhelium
-pkgver=1.8.9
-pkgrel=2
+pkgver=1.8.10
+pkgrel=1
pkgdesc="The application framework for tauOS apps."
arch=('x86_64' 'aarch64')
depends=('gtk4' 'glib2' 'libgee')
@@ -17,13 +17,18 @@ makedepends=(
url="https://github.com/tau-OS/libhelium"
license=('LGPL3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('8ec5fa64f64b77524993b959d6309798f35fa8326bbad5ec28a59f15b562e532')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$pkgver.tar.gz"
+ "$pkgname.patch")
+sha256sums=('f4963b7196e6456d6ba733f24ec7a746d1372ac84bd7677a4d960606b4e3c5c3'
+ '332dea0fe8126f5e347e17f11dbaad5b565c7f99cf20424e7711aa29011ec858')
prepare() {
cd "$srcdir/libhelium-$pkgver"
meson subprojects download
+
+ # Removes the automatic schema compilation, we're doing this ourselves
+ patch --strip=1 --input="$srcdir/$pkgname.patch"
}
build() {
@@ -37,4 +42,9 @@ package() {
cd "$srcdir/libhelium-$pkgver"
meson install -C builddir --destdir "$pkgdir"
+
+ # Manually add the schema into the right data dir.
+ # We don't have to call glib-compile-schemas as glib2 contains a hook:
+ # <https://gitlab.archlinux.org/archlinux/packaging/packages/glib2/-/blob/main/glib-compile-schemas.hook?ref_type=heads>
+ install -Dm644 data/com.fyralabs.desktop.appearance.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/com.fyralabs.desktop.appearance.gschema.xml"
}