summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormickybart2018-06-25 02:30:50 -0400
committermickybart2018-06-25 02:30:50 -0400
commitf4e3534f2d31699af1a141d437ad256559fc4c26 (patch)
tree532de4e5a22a79d5d53434341b7681ac2e50d5b9 /PKGBUILD
parent8fecb844da568c4c4fb8b0400873e74fdcf9f025 (diff)
downloadaur-libhybris-git.tar.gz
support aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bed214527678..fb39da287623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgbase=libhybris-git
pkgname=('libhybris-git' 'libhybris-libgl-git' 'libhybris-wayland-egl-git')
_pkgbase=libhybris
-pkgver=1237.cfd9823
-pkgrel=2
-arch=('armv7h')
+pkgver=1303.07b547e
+pkgrel=1
+arch=('armv7h' 'aarch64')
url="https://github.com/libhybris/libhybris"
license=('Apache')
makedepends=('wayland' 'hybris-android-headers')
@@ -25,7 +25,22 @@ prepare() {
build() {
cd "${srcdir}/${_pkgbase}/hybris"
+ # set target arch for libhybris
+ case "$CARCH" in
+ "armv7h")
+ _carch="arm"
+ ;;
+ "aarch64")
+ _carch="arm64"
+ ;;
+ *)
+ _carch="$CARCH"
+ esac
+
+ echo "Target architecture for libhybris: $_carch"
+
./autogen.sh \
+ --enable-arch=$_carch \
--prefix=/opt/android/hybris \
--with-android-headers=/opt/android/include \
--enable-wayland