summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-11 15:36:39 +0800
committerChocobo12023-04-11 15:37:11 +0800
commit6f322f16c1b3fdacfe4112b891a29267a8360d4d (patch)
treea8f29bf28c5356b4b0ecd66403a673d4c8e55131 /PKGBUILD
parentc4a9b299ae3afabbe4057b50d56bfa83ac6e5461 (diff)
downloadaur-libidn-git.tar.gz
upgpkg: libidn-git 1.41.r30.g674e0fe1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c94e041a1b8..f53b04b39309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libidn-git
-pkgver=1.33.r47.g13f07cbf
-pkgrel=2
+pkgver=1.41.r30.g674e0fe1
+pkgrel=1
pkgdesc="An implementation of the Stringprep, Punycode and IDNA 2003 specifications"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/libidn/"
license=('GPL' 'LGPL')
depends=('glibc')
makedepends=('git' 'gengetopt' 'gperf' 'gtk-doc' 'fig2dev' 'ghostscript')
-provides=('libidn')
+provides=("libidn=$pkgver")
conflicts=('libidn')
options=('staticlibs')
source=("git+https://git.savannah.gnu.org/git/libidn.git")
@@ -19,14 +19,18 @@ sha256sums=('SKIP')
pkgver() {
cd "libidn"
- git describe --long --tags | sed 's/^libidn.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
cd "libidn"
make bootstrap
- ./configure --prefix="/usr"
+ ./configure \
+ --prefix="/usr"
make
}