summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-03 15:43:43 +0800
committerChocobo12017-08-03 16:17:34 +0800
commitdd3650a5298aa9fba678826320691ae021f7188b (patch)
treef3cc7862a92b0133c9f83045491854e97f78647c /PKGBUILD
downloadaur-dd3650a5298aa9fba678826320691ae021f7188b.tar.gz
newpkg: libidn2-git 2.0.3.r11.g015135e-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57fc45fc2ebe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libidn2-git
+pkgver=2.0.3.r11.g015135e
+pkgrel=1
+pkgdesc="An implementation of IDNA 2008 and TR46"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/libidn/#libidn2"
+license=('GPL' 'LGPL')
+depends=('glibc' 'libunistring')
+makedepends=('git' 'gengetopt' 'gtk-doc')
+provides=('libidn2')
+conflicts=('libidn2')
+source=("git+https://gitlab.com/libidn/libidn2.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libidn2"
+
+ git describe --long --tags | sed 's/^libidn2.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libidn2"
+
+ ./bootstrap
+ ./configure --prefix="/usr" --enable-gtk-doc
+ make
+}
+
+check() {
+ cd "libidn2"
+
+ make check
+}
+
+package() {
+ cd "libidn2"
+
+ make DESTDIR="$pkgdir" install
+}